Get in touch
Back
Maintenance

Planned Maintenance

Completed 12 Jan at 04:20pm UTC.

ThorNode US East 1 - Virginia - Solana ThorNode US East 2- New York - Solana
Completed

Maintenance completed

Posted 12 Jan at 04:20pm UTC.
Started

Planned Network Maintenance

Posted 12 Jan at 03:30pm UTC.