Back
Downtime

ThorNode EU - Germany, ThorNode US Prime #2, ThorNode US Prime #3, ThorNode US Prime #4, and 2 other services are down
Started 5 Mar at 06:26pm UTC, resolved 5 Mar at 09:14pm UTC.
Resolved
ThorNode EU - Germany, ThorNode US Prime #2, ThorNode US Prime #3, and 1 other resource recovered.
Posted 5 Mar at 09:14pm UTC.

Re-appeared
ThorNode EU - Germany, ThorNode US Prime #2, ThorNode US Prime #3, and 1 other resource went down.
Posted 5 Mar at 07:27pm UTC.
Resolved
ThorNode EU - Germany, ThorNode US Prime #2, ThorNode US Prime #3, and 1 other resource recovered.
Posted 5 Mar at 07:13pm UTC.

Created
ThorNode EU - Germany, ThorNode US Prime #2, ThorNode US Prime #3, and 1 other resource went down.
Posted 5 Mar at 06:26pm UTC.