Get in touch
Back
Maintenance

Solana Validator Upgrade

Completed 19 Sep at 01:00pm UTC.

ThorNode DE - Germany - Solana ThorNode US East 1 - Virginia - Solana ThorNode US East 2- New York - Solana
Completed

Maintenance completed

Posted 19 Sep at 01:00pm UTC.
Started

Solana Validator Upgrade

Posted 19 Sep at 10:30am UTC.