Back
Resolved

Solana network issues
Started 16 Jan at 03:45am UTC.
ThorNode US East 2- New York - Solana
Created
The Solana network in New York is currently experiencing connectivity issues due to unstable connections with several validators. This is leading to increased latency and intermittent access for users. Efforts are underway to stabilize these connections and restore normal operations as quickly as possible.
Posted 16 Jan at 03:45am UTC.