Get in touch
Back
Resolved

ISP Network Maintenance

Started 12 Feb at 08:16pm UTC.

ThorNode US East 2- New York - Solana
Created

Our ISP is performing maintenance, which may result in higher ping times. We appreciate your patience during this period.

Posted 12 Feb at 08:16pm UTC.