Get in touch
Back
Maintenance

Solana NY Node Infrastructure Upgrade

Completed 16 Mar at 08:00am UTC.

ThorNode US East 2- New York - Solana
Completed

Maintenance completed

Posted 16 Mar at 08:00am UTC.
Started

Solana New York Node Infrastructure will be upgraded to improve network capability. Connection issues may occur during maintenance.

Posted 16 Mar at 03:00am UTC.