Back
Maintenance

Solana London RPC Node Update
Completed 26 Mar at 10:00am UTC.
ThorNode LDN - United Kingdom - Solana
Completed
Maintenance completed
Posted
26 Mar at 10:00am UTC.

Started
The RPC Node has undergone necessary Solana Core updates.
Posted
26 Mar at 08:50am UTC.