Get in touch
Back
Maintenance

ThorLab Bots General Mainentance

Completed 30 Mar at 06:17pm UTC.

Dashboard Services
Completed

Maintenance completed and all services are operational.

Posted 30 Mar at 06:17pm UTC.
Started

All ThorNode holder infrastructure is undergoing maintenance. Users are not able to do holder verification or rent/auth IPs until ends.

Posted 30 Mar at 10:00am UTC.