Get in touch
Back
Maintenance

Solana RPC Network Maintenance

Completed 12 Aug at 11:00am UTC.

ThorNode US East 2- New York - Solana
Completed

Maintenance completed

Posted 12 Aug at 11:00am UTC.
Started

There will be a short network maintenance at ThorNode New York Solana RPCs.

Posted 12 Aug at 09:45am UTC.