Get in touch
Back
Maintenance

General Maintenance

Completed 25 Jan at 04:30pm UTC.

ThorNode AMS - Netherlands - Solana ThorNode US East 1 - Virginia - Solana ThorNode US East 2- New York - Solana
Completed

Maintenance completed

Posted 25 Jan at 04:30pm UTC.
Started

There will be a short maintenance at ThorNode RPCs.

Posted 24 Jan at 11:30pm UTC.