Get in touch
Back
Resolved

Some services are down

Started 25 Jan at 10:23pm UTC.

ThorNode SLC - Salt Lake City - Solana
Created

ThorNode SLC - Salt Lake City:

Critical routing issue impacting ThorNode SLC location. Engineering team engaged with provider. Updates pending resolution.

Posted 25 Jan at 10:23pm UTC.