Get in touch
Back
Maintenance

Scheduled Maintenance Notification

Completed 31 Jan at 11:20pm UTC.

Dashboard Services
Completed

Maintenance completed

Posted 31 Jan at 11:20pm UTC.
Started

ThorNode Dashboard Services and Discord Bots will undergo scheduled maintenance to improve performance and stability.

Posted 31 Jan at 06:20pm UTC.