Get in touch
Back
Maintenance

Geyser update

Completed 19 Feb at 12:00pm UTC.

ThorNode US West 2 - Los Angeles - Solana
Completed

Maintenance completed

Posted 19 Feb at 12:00pm UTC.
Started

Geyser v0.3.1 update

Posted 19 Feb at 11:00am UTC.