Get in touch
Back
Maintenance

Solana RPC network upgrade in Amsterdam

Completed 25 Apr at 03:00pm UTC.

ThorNode AMS - Netherlands - Solana
Completed

Maintenance completed

Posted 25 Apr at 03:00pm UTC.
Started

Solana RPC maintenance is underway in our Amsterdam location; brief interruptions or latency may occur. Please use alternate regions in the meantime.

Posted 23 Apr at 04:00pm UTC.