Get in touch
Back
Maintenance

Network Maintenance

Completed 9 May at 02:30pm UTC.

ThorNode AMS - Netherlands - Solana
Completed

Maintenance completed

Posted 9 May at 02:30pm UTC.
Started

Solana RPC maintenance is underway in our Amsterdam location; brief interruptions or latency may occur. Please use alternate regions in the meantime.

Posted 8 May at 08:28pm UTC.