Back
Maintenance

Solana RPC Network Maintenance in Amsterdam Location
Completed 10 Jul at 07:40pm UTC.
ThorNode AMS - Netherlands - Solana
Completed
Maintenance completed
Posted
10 Jul at 07:40pm UTC.

Started
We are currently performing scheduled maintenance on the Solana RPC network in our Amsterdam location. During this time, users may experience temporary connectivity issues or degraded performance.
Posted
9 Jul at 07:40pm UTC.