Get in touch
Back
Maintenance

Solana RPC Network Maintenance in London Location

Completed 10 Jul at 08:00pm UTC.

ThorNode LDN - United Kingdom - Solana
Completed

Maintenance completed

Posted 10 Jul at 08:00pm UTC.
Started

We are currently performing scheduled maintenance on the Solana RPC network in our London location. During this time, users may experience temporary connectivity issues or degraded performance.

Posted 10 Jul at 05:00pm UTC.