Back
Maintenance

Solana RPC Network Maintenance on LAX node
Completed 1 Oct at 05:00pm UTC.
ThorNode US West 2 - Los Angeles - Solana
Completed
Maintenance completed
Posted
1 Oct at 05:00pm UTC.

Started
A network maintenance will be held on LAX node.
Posted
1 Oct at 03:00pm UTC.